Re: [PATCH] scsi: ufs: Use wait-for-reg in HCE init

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 10/14/24 9:57 PM, Avri Altman wrote:
Instead of open-coding it.  Code simplification - no functional change.

Please use full sentences in the patch description.

+	while (retry) {

Please change this loop from a while-loop into a for-loop.

+		if (!ufshcd_wait_for_register(hba, REG_CONTROLLER_ENABLE, CONTROLLER_ENABLE,
+					      CONTROLLER_ENABLE, 1000, 50)) {
+			break;
  		} else {

"else" is not needed after a "break" statement, isn't it?

+			dev_err(hba->dev, "Controller enable failed\n");

Please fix the grammar of this message, e.g. by changing this message
into "Enabling controller failed" or "Enabling the controller failed".

Thanks,

Bart.




[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Index of Archives]     [SCSI Target Devel]     [Linux SCSI Target Infrastructure]     [Kernel Newbies]     [IDE]     [Security]     [Git]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux ATA RAID]     [Linux IIO]     [Samba]     [Device Mapper]

  Powered by Linux