On 9/30/24 1:18 PM, Bart Van Assche wrote: > There is agreement that the word "slave" should not be used in Linux > kernel source code. Hence this patch that renames .slave_alloc() into New uses should be avoided.... However, I don't object to the patch. > .device_alloc() and .slave_destroy() into .device_destroy() in the SCSI > core, SCSI drivers, ATA drivers and also in the SCSI documentation. > Do not modify Documentation/scsi/ChangeLog.lpfc. No functionality has > been changed. > > This patch has been created as follows: > * Change the text "slave_alloc" into "device_alloc" in all source files > except in the LPFC driver changelog. > * Change the text "slave_destroy" into "device_destroy" in all source > files except in the LPFC driver changelog. > * Rename lpfc_no_slave() into lpfc_no_device(). > * Manually adjust whitespace where necessary to restore vertical > alignment (dc395x driver and include/linux/libata.h). > > Cc: Damien Le Moal <dlemoal@xxxxxxxxxx> > Signed-off-by: Bart Van Assche <bvanassche@xxxxxxx> > --- > Documentation/scsi/scsi_mid_low_api.rst | 50 +++++++++++------------ > drivers/ata/libata-scsi.c | 12 +++--- > drivers/firewire/sbp2.c | 4 +- > drivers/message/fusion/mptfc.c | 12 +++--- > drivers/message/fusion/mptsas.c | 8 ++-- > drivers/message/fusion/mptscsih.c | 6 +-- > drivers/message/fusion/mptscsih.h | 2 +- > drivers/message/fusion/mptspi.c | 12 +++--- > drivers/net/ethernet/mellanox/mlx4/main.c | 12 +++--- > drivers/s390/scsi/zfcp_scsi.c | 10 ++--- > drivers/s390/scsi/zfcp_sysfs.c | 2 +- > drivers/s390/scsi/zfcp_unit.c | 2 +- > drivers/scsi/53c700.c | 12 +++--- > drivers/scsi/aic7xxx/aic79xx_osm.c | 4 +- > drivers/scsi/aic7xxx/aic7xxx_osm.c | 4 +- > drivers/scsi/bfa/bfad_im.c | 20 ++++----- > drivers/scsi/bnx2fc/bnx2fc_fcoe.c | 2 +- > drivers/scsi/csiostor/csio_scsi.c | 12 +++--- > drivers/scsi/dc395x.c | 12 +++--- > drivers/scsi/esp_scsi.c | 8 ++-- > drivers/scsi/fcoe/fcoe.c | 2 +- > drivers/scsi/fnic/fnic_main.c | 4 +- > drivers/scsi/hisi_sas/hisi_sas.h | 2 +- > drivers/scsi/hisi_sas/hisi_sas_main.c | 6 +-- > drivers/scsi/hisi_sas/hisi_sas_v1_hw.c | 2 +- > drivers/scsi/hisi_sas/hisi_sas_v2_hw.c | 2 +- > drivers/scsi/hisi_sas/hisi_sas_v3_hw.c | 2 +- > drivers/scsi/hpsa.c | 12 +++--- > drivers/scsi/ibmvscsi/ibmvfc.c | 6 +-- > drivers/scsi/ipr.c | 12 +++--- > drivers/scsi/libfc/fc_fcp.c | 6 +-- > drivers/scsi/libsas/sas_scsi_host.c | 4 +- > drivers/scsi/lpfc/lpfc_scsi.c | 22 +++++----- > drivers/scsi/megaraid/megaraid_sas_base.c | 8 ++-- > drivers/scsi/mpi3mr/mpi3mr_os.c | 12 +++--- > drivers/scsi/mpt3sas/mpt3sas_scsih.c | 16 ++++---- > drivers/scsi/myrb.c | 16 ++++---- > drivers/scsi/myrs.c | 8 ++-- > drivers/scsi/ncr53c8xx.c | 4 +- > drivers/scsi/pmcraid.c | 14 +++---- > drivers/scsi/qla2xxx/qla_os.c | 8 ++-- > drivers/scsi/qla4xxx/ql4_os.c | 6 +-- > drivers/scsi/scsi_debug.c | 12 +++--- > drivers/scsi/scsi_scan.c | 8 ++-- > drivers/scsi/scsi_sysfs.c | 4 +- > drivers/scsi/smartpqi/smartpqi_init.c | 8 ++-- > drivers/scsi/snic/snic_main.c | 6 +-- > drivers/scsi/storvsc_drv.c | 2 +- > drivers/scsi/sym53c8xx_2/sym_glue.c | 10 ++--- > drivers/scsi/virtio_scsi.c | 2 +- > drivers/scsi/xen-scsifront.c | 4 +- > drivers/staging/rts5208/rtsx.c | 4 +- > drivers/ufs/core/ufshcd.c | 12 +++--- > drivers/usb/image/microtek.c | 4 +- > drivers/usb/storage/scsiglue.c | 6 +-- > drivers/usb/storage/uas.c | 4 +- > include/linux/libata.h | 8 ++-- > include/scsi/libfc.h | 2 +- > include/scsi/libsas.h | 4 +- > include/scsi/scsi_device.h | 4 +- > include/scsi/scsi_host.h | 16 ++++---- > 61 files changed, 250 insertions(+), 250 deletions(-) >