On 10/1/24 05:18, Bart Van Assche wrote: > There is agreement that the word "slave" should not be used in Linux > kernel source code. Hence this patch that renames .slave_alloc() into > .device_alloc() and .slave_destroy() into .device_destroy() in the SCSI > core, SCSI drivers, ATA drivers and also in the SCSI documentation. > Do not modify Documentation/scsi/ChangeLog.lpfc. No functionality has > been changed. > > This patch has been created as follows: > * Change the text "slave_alloc" into "device_alloc" in all source files > except in the LPFC driver changelog. Looks good, but like Matthew, I think sdev_xxx may be better names as they make it clear that the operations take a struct scsi_device. But I will not hold this series for that though. The patch is really big too, so maybe move the documentation changes together with patch 4 ? Also, please send the cover letter to everyone. Having to look at all patch titles to try to figure out what your patches do overall is not fun. > * Change the text "slave_destroy" into "device_destroy" in all source > files except in the LPFC driver changelog. > * Rename lpfc_no_slave() into lpfc_no_device(). > * Manually adjust whitespace where necessary to restore vertical > alignment (dc395x driver and include/linux/libata.h). > > Cc: Damien Le Moal <dlemoal@xxxxxxxxxx> > Signed-off-by: Bart Van Assche <bvanassche@xxxxxxx> [...] > diff --git a/include/linux/libata.h b/include/linux/libata.h > index 9b4a6ff03235..e04184b6d79b 100644 > --- a/include/linux/libata.h > +++ b/include/linux/libata.h > @@ -1201,10 +1201,10 @@ extern int ata_std_bios_param(struct scsi_device *sdev, > struct block_device *bdev, > sector_t capacity, int geom[]); > extern void ata_scsi_unlock_native_capacity(struct scsi_device *sdev); > -extern int ata_scsi_slave_alloc(struct scsi_device *sdev); > +extern int ata_scsi_device_alloc(struct scsi_device *sdev); While at it, drop the extern. > int ata_scsi_device_configure(struct scsi_device *sdev, > struct queue_limits *lim); > -extern void ata_scsi_slave_destroy(struct scsi_device *sdev); > +extern void ata_scsi_device_destroy(struct scsi_device *sdev); Here too. > extern int ata_scsi_change_queue_depth(struct scsi_device *sdev, > int queue_depth); > extern int ata_change_queue_depth(struct ata_port *ap, struct scsi_device *sdev, > @@ -1460,8 +1460,8 @@ extern const struct attribute_group *ata_common_sdev_groups[]; > .this_id = ATA_SHT_THIS_ID, \ > .emulated = ATA_SHT_EMULATED, \ > .proc_name = drv_name, \ > - .slave_alloc = ata_scsi_slave_alloc, \ > - .slave_destroy = ata_scsi_slave_destroy, \ > + .device_alloc = ata_scsi_device_alloc, \ > + .device_destroy = ata_scsi_device_destroy, \ > .bios_param = ata_std_bios_param, \ > .unlock_native_capacity = ata_scsi_unlock_native_capacity,\ > .max_sectors = ATA_MAX_SECTORS_LBA48 -- Damien Le Moal Western Digital Research