Hi Martin, This patch series includes four patches that modify the UFS driver UIC code without modifying the behavior of that code. Please consider this patch series for the next merge window. Thanks, Bart. Changes compared to v2 of this patch series: - Dropped patch "Change the approach for power change UIC commands". - Added patch "Make ufshcd_uic_cmd_compl() easier to analyze". Changes compared to v1 of this patch series: - A patch that improves the struct ufs_hba documentation has been added. - Patch 2/2 has been split into two patches. - Instead of leaving the UIC completion interrupt enabled, disable it if UFSHCD_QUIRK_DISABLE_UIC_INTR_FOR_PWR_CMDS has been set. Bart Van Assche (4): scsi: ufs: core: Improve the struct ufs_hba documentation scsi: ufs: core: Make ufshcd_uic_cmd_compl() easier to read scsi: ufs: core: Make ufshcd_uic_cmd_compl() easier to analyze scsi: ufs: core: Always initialize the UIC done completion drivers/ufs/core/ufshcd.c | 38 ++++++++++++++++++++------------------ include/ufs/ufshcd.h | 7 ++++--- 2 files changed, 24 insertions(+), 21 deletions(-)