On 8/19/24 4:25 PM, Damien Le Moal wrote:
On 8/10/24 04:31, Bart Van Assche wrote:
+ if (blk_rq_is_passthrough(req) &&
+ !(scmd->flags & SCMD_RETRY_PASSTHROUGH))
return true;
return false;
return (req->cmd_flags & REQ_FAILFAST_DEV) ||
(blk_rq_is_passthrough(req) &&
!(scmd->flags & SCMD_RETRY_PASSTHROUGH));
maybe ? Not necessarily more readable though.
diff --git a/include/scsi/scsi_cmnd.h b/include/scsi/scsi_cmnd.h
index 45c40d200154..19c57446ab23 100644
--- a/include/scsi/scsi_cmnd.h
+++ b/include/scsi/scsi_cmnd.h
@@ -58,8 +58,11 @@ struct scsi_pointer {
*/
#define SCMD_FORCE_EH_SUCCESS (1 << 3)
#define SCMD_FAIL_IF_RECOVERING (1 << 4)
+/* If set, retry a passthrough command in case of a unit attention. */
"...in case of error". There are other sense keys than unit attention and there
is no code checking that this flag applies only to unit attention.
Hi Damien,
Thanks for the detailed feedback. Since Martin replied to this series
that he will reconcile his changes with mine, I plan to wait until
either Martin posts his patches or until Martin asks me to repost my
patches.
Thanks,
Bart.