The current UFS controller of R-Car S4-8 ES 1.0 only requires statical values for initializing it. However, other UFS controller (R-Car S4-8 ES 1.2) will require dynamic values like eFuse values. So, refactor the code for it. For now, readling eFuse values function which Geert-san made is under review [1]. So, this patch series refactors is the code only. [1] https://lore.kernel.org/all/cover.1716974502.git.geert+renesas@xxxxxxxxx/ Changes from v1: https://lore.kernel.org/all/20240708120931.1703956-1-yoshihiro.shimoda.uh@xxxxxxxxxxx/ - Combine the declaration and assignments into a single statement in patch 1/5. - Fix build error when only the patch 1/5 is applied. - Further refactoring the code by removing a helper function, not only using udelay() directly in patch 3/5. - Rename some functions to s/ufs_renesas_param_/ufs_renesas_/. Yoshihiro Shimoda (5): scsi: ufs: renesas: Refactor init code for other UFS controller scsi: ufs: renesas: Remove a static local variable scsi: ufs: renesas: Remove a register controll helper function scsi: ufs: renesas: Refactoring specific PHY settings of 0x10a[df] scsi: ufs: renesas: Add reusable functions drivers/ufs/host/ufs-renesas.c | 525 +++++++++++++++------------------ 1 file changed, 237 insertions(+), 288 deletions(-) -- 2.25.1