On 5/30/24 2:36 PM, Bao D. Nguyen wrote:
+enum { + UIC_CMD_TIMEOUT = 500, + UIC_CMD_TIMEOUT_MAX = 2000, +};
Since UIC_CMD_TIMEOUT_MAX has been introduced, please rename UIC_CMD_TIMEOUT into UIC_CMD_TIMEOUT_DEFAULT or UIC_CMD_TIMEOUT_MIN to
make the role of that constant more clear.
+static unsigned int uic_cmd_timeout = UIC_CMD_TIMEOUT; +module_param_cb(uic_cmd_timeout, &uic_cmd_timeout_ops, &uic_cmd_timeout, 0644); +MODULE_PARM_DESC(uic_cmd_timeout, + "UFS UIC command timeout in milliseconds. Default to 500ms. Supported values range from 500ms to 2 seconds inclusively");
Default to -> Defaults to?
+ +
A single blank line should be sufficient. Once these comments have been addressed, feel free to add: Reviewed-by: Bart Van Assche <bvanassche@xxxxxxx>