On 4/5/24 03:31, Bart Van Assche wrote: >> diff --git a/block/blk-mq.c b/block/blk-mq.c >> index 88b541e8873f..2c6a317bef7c 100644 >> --- a/block/blk-mq.c >> +++ b/block/blk-mq.c >> @@ -828,6 +828,8 @@ static void blk_complete_request(struct request *req) >> bio = next; >> } while (bio); >> >> + blk_zone_write_complete_request(req); > > Same comment here as above: the function name > blk_zone_write_complete_request() is misleading since that function is > called for all request types and not only for zoned writes. Please > rename blk_zone_write_complete_request() into > blk_zone_complete_request(). > >> + /* >> + * If the plug has a cached request for this queue, try use it. >> + */ > > try use it -> try to use it (I know this comes from upstream code). > >> + if (blk_queue_is_zoned(q) && blk_zone_write_plug_bio(bio, nr_segs)) >> + goto queue_exit; > > The order of words in the blk_zone_write_plug_bio() function name seems > unusual to me. How about renaming that function into > blk_zone_plug_write_bio()? To be consistent with your other renaming ideas, what about "blk_zone_plug_bio()" ? -- Damien Le Moal Western Digital Research