On 3/8/23 21:28, Bao D. Nguyen wrote:
+static bool ufshcd_mcq_sqe_search(struct ufs_hba *hba, + struct ufs_hw_queue *hwq, int task_tag) +{ + struct utp_transfer_req_desc *utrd; + u32 mask = hwq->max_entries - 1; + bool ret = false; + u64 addr, match; + u32 i;
The variable name "i" is usually used for a loop index. In this case it represents a slot in the submission queue. How about renaming "i" into "slot"?
+static inline void ufshcd_mcq_update_sq_head_slot(struct ufs_hw_queue *q) +{ + u32 val = readl(q->mcq_sq_head); + + q->sq_head_slot = val / sizeof(struct utp_transfer_req_desc); +}
Please modify this function such that it returns the head slot value instead of storing it in a member variable and remove the sq_head_slot member variable. Storing the sq_head_slot value in a member variable seems wrong to me since the value of that variable will be outdated as soon as the submission queue is restarted.
+static inline bool ufshcd_mcq_is_sq_empty(struct ufs_hw_queue *q) +{ + return q->sq_head_slot == q->sq_tail_slot; +}
Please remove this function and inline this function into its callers. Thanks, Bart.