On Mon, Mar 06, 2023 at 10:48:04AM -0800, Linus Torvalds wrote: > On Mon, Mar 6, 2023 at 8:07 AM Vernon Yang <vernon2gm@xxxxxxxxx> wrote: > > > > - if (new_cpu == nr_cpumask_bits) > > + if (new_cpu >= nr_cpumask_bits) > > This all should use "nr_cpu_ids", not "nr_cpumask_bits". > > But I really suspect that it should all be rewritten to not do that > thing over and over, but just use a helper function for it. > > int lpfc_next_present_cpu(int n, int alternate) > { > n = cpumask_next(n, cpu_present_mask); > if (n >= nr_cpu_ids) > n = alternate; > return n; > } > > and then you could just use > > start_cpu = lpfc_next_present_cpu(new_cpu, first_cpu); OK, thanks you very much. I'll send a second version shortly > > or similar. > > Linus > > PS. We "kind of" already have a helper function for this: > cpumask_next_wrap(). But it's really meant for a different pattern > entirely, so let's not confuse things.