On Wed, Feb 15, 2023 at 08:37:45PM +0800, Po-Wen Kao wrote: > Transfer command descriptor is allocated in ufshcd_memory_alloc() > and referenced by transfer request descriptor with stride size > sizeof_utp_transfer_cmd_desc() > instead of > sizeof(struct utp_transfer_cmd_desc). > > Consequently, computing tag by address offset should also refer to the > same stride. > > Signed-off-by: Po-Wen Kao <powen.kao@xxxxxxxxxxxx> Fixes tag? > --- > drivers/ufs/core/ufs-mcq.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/ufs/core/ufs-mcq.c b/drivers/ufs/core/ufs-mcq.c > index 31df052fbc41..3a27fa4b0024 100644 > --- a/drivers/ufs/core/ufs-mcq.c > +++ b/drivers/ufs/core/ufs-mcq.c > @@ -265,7 +265,7 @@ static int ufshcd_mcq_get_tag(struct ufs_hba *hba, > addr = (le64_to_cpu(cqe->command_desc_base_addr) & CQE_UCD_BA) - > hba->ucdl_dma_addr; > > - return div_u64(addr, sizeof(struct utp_transfer_cmd_desc)); > + return div_u64(addr, sizeof_utp_transfer_cmd_desc(hba)); I think it is not a good practice to name variables after the standard operators like sizeof(). It is confusing at its best. How about renaming this function to get_ucd_size() or something relevant? But the change itself LGTM! Reviewed-by: Manivannan Sadhasivam <mani@xxxxxxxxxx> Thanks, Mani > } > > static void ufshcd_mcq_process_cqe(struct ufs_hba *hba, > -- > 2.18.0 > -- மணிவண்ணன் சதாசிவம்