[PATCH v3 0/3] Simplify ufshcd_execute_start_stop()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi Martin,

This patch series simplifies ufshcd_execute_start_stop() by using the new
scsi_execute_cmd() function instead of open-coding it. Please consider this
patch for the next merge window.

Thanks,

Bart.

Changes compared to v2:
- Changed the type of scsi_exec_args.scmd_flags from unsigned int into int.
- Left out a WARN_ON_ONCE() statement from patch 2/3 that was removed by patch
  3/3 anyway.

Changes compared to v1:
- Addressed John's feedback that RQF_PM should always be set if BLK_MQ_REQ_PM
  is set.
- Added a third patch that makes RQF_PM to be set implicitly.

Bart Van Assche (3):
  scsi: core: Extend struct scsi_exec_args
  scsi: ufs: Rely on the block layer for setting RQF_PM
  scsi: ufs: Simplify ufshcd_execute_start_stop()

 drivers/scsi/scsi_lib.c    |  1 +
 drivers/ufs/core/ufshcd.c  | 35 ++++++++---------------------------
 include/scsi/scsi_device.h |  1 +
 3 files changed, 10 insertions(+), 27 deletions(-)




[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Index of Archives]     [SCSI Target Devel]     [Linux SCSI Target Infrastructure]     [Kernel Newbies]     [IDE]     [Security]     [Git]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux ATA RAID]     [Linux IIO]     [Samba]     [Device Mapper]

  Powered by Linux