On 11/4/22 16:19, Mike Christie wrote:
+ static const u8 cmd[10] = { SYNCHRONIZE_CACHE }; + int res;
[ ... ]
+ /* + * Leave the rest of the command zero to indicate flush everything. + */ + res = scsi_exec_req(((struct scsi_exec_args) { + .sdev = sdp, + .cmd = cmd, + .data_dir = DMA_NONE, + .sshdr = sshdr, + .timeout = timeout, + .retries = sdkp->max_retries, + .req_flags = RQF_PM, + .failures = failures }));
The "leave the rest" comment seems misplaced to me. I think it should be moved above the cmd[10] definition. If that comment is moved, please add:
Reviewed-by: Bart Van Assche <bvanassche@xxxxxxx>