On Thu, Jul 19 2007, Geert Uytterhoeven wrote: > On Thu, 19 Jul 2007, Andrew Morton wrote: > > On Thu, 19 Jul 2007 11:02:07 +0200 (CEST) Geert Uytterhoeven <Geert.Uytterhoeven@xxxxxxxxxxx> wrote: > > > > > On Wed, 18 Jul 2007, Andrew Morton wrote: > > > > > +struct ps3rom_private { > > > > > + struct ps3_storage_device *dev; > > > > > + struct scsi_cmnd *curr_cmd; > > > > > +}; > > > > > +#define ps3rom_priv(dev) ((dev)->sbd.core.driver_data) > > > > > + > > > > > > > > Someone should invent a keyboard which delivers an electric shock when the > > > > operator types "#define". In the meanwhile, I get to do the honours. > > > > > > > > Please don't implement in a macro anything which can be implemented in C. > > > > > > All I needed was a shorthand to access driver_data, for both read and write > > > access (you cannot do the latter with C, unless you decouple read and write). > > > > Oh dear. > > > > ps3rom_priv(dev) = host; > > > > that's 'orrid. We have an identifier pretending to be a function, only we > > go and treat it as an lvalue. > > > > I mean, C code should look like C code, and the above just doesn't. > > > > Sigh. > > Do you prefer > > static inline struct ps3rom_private *ps3rom_priv_get(struct ps3_storage_device > *dev) > { > return dev->sbd.core.driver_data; > } > > static inline void ps3rom_priv_set(struct ps3_storage_device *dev, > struct ps3rom_private *priv) > { > dev->sbd.core.driver_data = priv; > } how about just killing them? it makes the code harder to read, what is the point of abstracting something like that out? -- Jens Axboe - To unsubscribe from this list: send the line "unsubscribe linux-scsi" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html