> > - for (pos = 0; pos < len; pos += 4) > > + for (pos = 0; pos < len; pos += 4) { > > + if (pos >= REG_UIC_ERROR_CODE_PHY_ADAPTER_LAYER && > > + pos <= REG_UIC_ERROR_CODE_DME) > > Doesn't that need to be 'pos + offset' not just 'pos' > For only ufshcd.c, offset is always zero, so 'offset' doesn't need to be referred to. But now I think the function is currently public to external modules. Okay, let me modify this. Thanks. Kiwoong Kim