On Thu, Nov 18, 2021 at 08:30:49PM -0800, Bart Van Assche wrote: > On 11/18/21 18:18, Ming Lei wrote: > > + bool alloc_srcu; > > I found the following statement multiple times in this patch: > > WARN_ON_ONCE(q->alloc_srcu != !!(q->tag_set->flags & BLK_MQ_F_BLOCKING)); > > Does this mean that the new q->alloc_srcu member variable can be left out > and that it can be replaced with the following test? > > q->tag_set->flags & BLK_MQ_F_BLOCKING q->tag_set can't be used anymore after blk_cleanup_queue() returns, and we need the flag for freeing request_queue instance. > > Please note that I'm not concerned about the memory occupied by this > variable but only about avoiding redundancy. > > If this variable is retained it probably should be renamed, e.g. "has_srcu" > instead of "alloc_srcu". Fine. Thanks, Ming