This series renames struct blk_keyslot_manager to struct blk_crypto_profile, as it is misnamed; it doesn't always manage keyslots. It's much more logical to think of it as the "blk-crypto profile" of a device, similar to blk_integrity_profile. This series also improves the inline-encryption.rst documentation file, and cleans up blk-crypto-fallback a bit. This series applies to block/for-next. Changed v3 => v4: - Rebased onto block/for-next to resolve a conflict due to 'struct request' being moved. Changed v2 => v3: - Made some minor tweaks to patches 3 and 4, mostly comments and documentation. - Clarified a commit message to mention no change in behavior. - Added a Reviewed-by tag. Changed v1 => v2: - Fixed a build error in blk-integrity.c. - Removed a mention of "ksm" from a comment. - Dropped the patch "blk-crypto-fallback: consolidate static variables". - Added Acked-by and Reviewed-by tags. Eric Biggers (4): blk-crypto-fallback: properly prefix function and struct names blk-crypto: rename keyslot-manager files to blk-crypto-profile blk-crypto: rename blk_keyslot_manager to blk_crypto_profile blk-crypto: update inline encryption documentation Documentation/block/inline-encryption.rst | 451 +++++++++-------- block/Makefile | 2 +- block/blk-crypto-fallback.c | 118 ++--- block/blk-crypto-profile.c | 565 +++++++++++++++++++++ block/blk-crypto.c | 29 +- block/blk-integrity.c | 4 +- block/keyslot-manager.c | 579 ---------------------- drivers/md/dm-core.h | 4 +- drivers/md/dm-table.c | 168 +++---- drivers/md/dm.c | 10 +- drivers/mmc/core/crypto.c | 11 +- drivers/mmc/host/cqhci-crypto.c | 33 +- drivers/scsi/ufs/ufshcd-crypto.c | 32 +- drivers/scsi/ufs/ufshcd-crypto.h | 9 +- drivers/scsi/ufs/ufshcd.c | 2 +- drivers/scsi/ufs/ufshcd.h | 6 +- include/linux/blk-crypto-profile.h | 166 +++++++ include/linux/blk-mq.h | 2 +- include/linux/blkdev.h | 16 +- include/linux/device-mapper.h | 4 +- include/linux/keyslot-manager.h | 120 ----- include/linux/mmc/host.h | 4 +- 22 files changed, 1204 insertions(+), 1131 deletions(-) create mode 100644 block/blk-crypto-profile.c delete mode 100644 block/keyslot-manager.c create mode 100644 include/linux/blk-crypto-profile.h delete mode 100644 include/linux/keyslot-manager.h base-commit: 655d78c1328cfede3dfd1ccafd8433692e23d21e -- 2.33.0