On Mon, Aug 16, 2021 at 06:57:18PM -0700, Kevin Mitchell wrote: > When scsi_dispatch_cmd was moved to scsi_lib.c and made static, some > compilers (i.e., at least gcc 8.4.0) decided to compile this > inline. This is a problem for lkdtm.ko, which needs to insert a kprobe > on this function for the SCSI_DISPATCH_CMD crashpoint. > > Move this crashpoint one function up the call chain to > scsi_queue_rq. Though this is also a static function, it should never be > inlined because it is assigned as a structure entry. Therefore, > kprobe_register should always be able to find it. Since there is already > precedent for crashpoint names not exactly matching their probed > functions, keep the name of the crashpoint the same for backwards > compatibility. > > Fixes: 82042a2cdb55 ("scsi: move scsi_dispatch_cmd to scsi_lib.c") > Signed-off-by: Kevin Mitchell <kevmitch@xxxxxxxxxx> This looks ok. Does any userspace hardcode these names or can we use a saner name? Btw, generic_ide_ioctl is gone as well, together with the whole legacy ide subsystem.