On 7/6/21 4:28 AM, Avri Altman wrote: > May I suggest to re-group the ufs part of this series so it can be reviewed more effectively: > - Cleanups (relatively simple & intuitive, so can it be picked up ?) > ufs: Reduce power management code duplication > ufs: Only include power management code if necessary > ufs: Rename the second ufshcd_probe_hba() argument > ufs: Use DECLARE_COMPLETION_ONSTACK() where appropriate > ufs: Remove ufshcd_valid_tag() > ufs: Verify UIC locking requirements at runtime > ufs: Improve static type checking for the host controller state > ufs: Remove several wmb() calls > ufs: Inline ufshcd_outstanding_req_clear() > ufs: Rename __ufshcd_transfer_req_compl() > > - Fixes of "Optimize host lock" (can those 2 be squashed ?) > ufs: Fix a race in the completion path > ufs: Use the doorbell register instead of the UTRLCNR register > > - Revamping ufs error handling > ufs: Fix the SCSI abort handler > ufs: Request sense data asynchronously > ufs: Synchronize SCSI and UFS error handling > ufs: Retry aborted SCSI commands instead of completing these successfully So this comes down to moving the "ufs: Fix the SCSI abort handler" later in this series? I will make this change. Thanks, Bart.