Hi Bart! > On 6/8/21 8:39 PM, Martin K. Petersen wrote: >> +static inline unsigned int scsi_get_block_count(struct scsi_cmnd *scmd) >> +{ >> + unsigned int shift = ilog2(scmd->device->sector_size) - SECTOR_SHIFT; >> + >> + return blk_rq_bytes(scmd->request) >> shift; >> +} > > I think we either need a comment above this function that explains that > the return value is a number of logical blocks or to change the function > name to make the meaning of the return value clear. I went with the scsi_get_ prefix to match the scsi_get_sectors() and scsi_get_lba() calls. Felt that "block" would suffice but I could make it scsi_logical_block_count() if you prefer? -- Martin K. Petersen Oracle Linux Engineering