On 4/16/21 1:26 AM, Dmitry Bogdanov wrote: > --- a/include/target/target_core_fabric.h > +++ b/include/target/target_core_fabric.h > @@ -89,6 +89,7 @@ struct target_core_fabric_ops { > void (*add_wwn_groups)(struct se_wwn *); > struct se_portal_group *(*fabric_make_tpg)(struct se_wwn *, > const char *); > + int (*fabric_enable_tpg)(struct se_portal_group *se_tpg, bool enable); > void (*fabric_drop_tpg)(struct se_portal_group *); > int (*fabric_post_link)(struct se_portal_group *, > struct se_lun *); A nit: the "fabric_" prefix is not useful inside struct target_core_fabric_ops. If the new callback would be called "enable_tpg" no clarity would be lost. Additionally, the "fabric_" prefix is deprecated. New target code should use the "target_" prefix for new functions. Thanks, Bart.