Re: [PATCH v5 14/31] elx: libefc: FC node ELS and state handling

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Sun, Jan 03, 2021 at 09:11:17AM -0800, James Smart wrote:
> This patch continues the libefc library population.
> 
> This patch adds library interface definitions for:
> - FC node PRLI handling and state management
> 
> Co-developed-by: Ram Vegesna <ram.vegesna@xxxxxxxxxxxx>
> Signed-off-by: Ram Vegesna <ram.vegesna@xxxxxxxxxxxx>
> Signed-off-by: James Smart <jsmart2021@xxxxxxxxx>
> Reviewed-by: Hannes Reinecke <hare@xxxxxxx>

Reviewed-by: Daniel Wagner <dwagner@xxxxxxx>

> ---
> v5:
>  Topology naming changes.


BTW, I've just grepped for TOPO and found

libefc_sli/sli4.h:      SLI4_READTOPO_ATTEN_TYPE        = 0xff,
libefc_sli/sli4.h:      SLI4_READTOPO_FLAG_IL           = 0x100,
libefc_sli/sli4.h:      SLI4_READTOPO_FLAG_PB_RECVD     = 0x200,
libefc_sli/sli4.h:      SLI4_READTOPO_LINKSTATE_RECV    = 0x3,
libefc_sli/sli4.h:      SLI4_READTOPO_LINKSTATE_TRANS   = 0xc,
libefc_sli/sli4.h:      SLI4_READTOPO_LINKSTATE_MACHINE = 0xf0,
libefc_sli/sli4.h:      SLI4_READTOPO_LINKSTATE_SPEED   = 0xff00,
libefc_sli/sli4.h:      SLI4_READTOPO_LINKSTATE_TF      = 0x40000000,
libefc_sli/sli4.h:      SLI4_READTOPO_LINKSTATE_LU      = 0x80000000,
libefc_sli/sli4.h:      SLI4_READTOPO_SCN_BBSCN         = 0xf,
libefc_sli/sli4.h:      SLI4_READTOPO_SCN_CBBSCN        = 0xf0,
libefc_sli/sli4.h:      SLI4_READTOPO_R_T_TOV           = 0x1ff,
libefc_sli/sli4.h:      SLI4_READTOPO_AL_TOV            = 0xf000,
libefc_sli/sli4.h:      SLI4_READTOPO_PB_FLAG           = 0x80,
libefc_sli/sli4.h:      SLI4_READTOPO_INIT_N_PORTID     = 0xffffff,
libefc_sli/sli4.h:      SLI4_READ_TOPOLOGY_LINK_UP      = 0x1,
libefc_sli/sli4.h:      SLI4_READ_TOPOLOGY_LINK_DOWN,
libefc_sli/sli4.h:      SLI4_READ_TOPOLOGY_LINK_NO_ALPA,
libefc_sli/sli4.h:      SLI4_READ_TOPO_UNKNOWN          = 0x0,
libefc_sli/sli4.h:      SLI4_READ_TOPO_NON_FC_AL,
libefc_sli/sli4.h:      SLI4_READ_TOPO_FC_AL,
libefc_sli/sli4.h:      SLI4_READ_TOPOLOGY_SPEED_NONE   = 0x00,
libefc_sli/sli4.h:      SLI4_READ_TOPOLOGY_SPEED_1G     = 0x04,
libefc_sli/sli4.h:      SLI4_READ_TOPOLOGY_SPEED_2G     = 0x08,
libefc_sli/sli4.h:      SLI4_READ_TOPOLOGY_SPEED_4G     = 0x10,
libefc_sli/sli4.h:      SLI4_READ_TOPOLOGY_SPEED_8G     = 0x20,
libefc_sli/sli4.h:      SLI4_READ_TOPOLOGY_SPEED_10G    = 0x40,
libefc_sli/sli4.h:      SLI4_READ_TOPOLOGY_SPEED_16G    = 0x80,
libefc_sli/sli4.h:      SLI4_READ_TOPOLOGY_SPEED_32G    = 0x90,
libefc_sli/sli4.h:      SLI4_READ_TOPOLOGY_SPEED_64G    = 0xa0,
libefc_sli/sli4.h:      SLI4_READ_TOPOLOGY_SPEED_128G   = 0xb0,

It's a bit confusing the SLI4_READTOPO vs SLI4_READ_TOPOLOGY_* vs
SLI4_READ_TOPO_* naming. But I don't have any idea to make it a bit more
readable.



[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Index of Archives]     [SCSI Target Devel]     [Linux SCSI Target Infrastructure]     [Kernel Newbies]     [IDE]     [Security]     [Git]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux ATA RAID]     [Linux IIO]     [Samba]     [Device Mapper]

  Powered by Linux