On 11/17/20 2:14 PM, Brian King wrote: > On 11/11/20 7:04 PM, Tyrel Datwyler wrote: >> The FC iu and response payloads are located at different offsets >> depending on the ibmvfc_cmd version. This is a result of the version 2 >> vfcFrame definition adding an extra 64bytes of reserved space to the >> structure prior to the payloads. >> >> Add helper routines to determine the current vfcFrame version and >> returning pointers to the proper iu or response structures within that >> ibmvfc_cmd. >> >> Signed-off-by: Tyrel Datwyler <tyreld@xxxxxxxxxxxxx> >> --- >> drivers/scsi/ibmvscsi/ibmvfc.c | 76 ++++++++++++++++++++++++---------- >> 1 file changed, 53 insertions(+), 23 deletions(-) >> >> diff --git a/drivers/scsi/ibmvscsi/ibmvfc.c b/drivers/scsi/ibmvscsi/ibmvfc.c >> index aa3445bec42c..5e666f7c9266 100644 >> --- a/drivers/scsi/ibmvscsi/ibmvfc.c >> +++ b/drivers/scsi/ibmvscsi/ibmvfc.c >> @@ -138,6 +138,22 @@ static void ibmvfc_tgt_move_login(struct ibmvfc_target *); >> >> static const char *unknown_error = "unknown error"; >> >> +static struct ibmvfc_fcp_cmd_iu *ibmvfc_get_fcp_iu(struct ibmvfc_host *vhost, struct ibmvfc_cmd *vfc_cmd) >> +{ >> + if (be64_to_cpu(vhost->login_buf->resp.capabilities) & IBMVFC_HANDLE_VF_WWPN) > > Suggest adding a flag to the vhost structure that you setup after login in order to > simplify this check and avoid chasing multiple pointers along with a byte swap. > > Maybe something like: > > vhost->is_v2 I considered that, but opted instead in my v2 respin to add a helper routine to test login response capabilities since we will also need to check for VIOS channel support. -Tyrel > >> + return &vfc_cmd->v2.iu; >> + else >> + return &vfc_cmd->v1.iu; >> +} >> + >> +static struct ibmvfc_fcp_rsp *ibmvfc_get_fcp_rsp(struct ibmvfc_host *vhost, struct ibmvfc_cmd *vfc_cmd) >> +{ >> + if (be64_to_cpu(vhost->login_buf->resp.capabilities) & IBMVFC_HANDLE_VF_WWPN) > > Same here > >> + return &vfc_cmd->v2.rsp; >> + else >> + return &vfc_cmd->v1.rsp; >> +} >> + >> #ifdef CONFIG_SCSI_IBMVFC_TRACE >> /** >> * ibmvfc_trc_start - Log a start trace entry > > >