On 2020-08-06 02:18, Daejun Park wrote: > > +static inline u32 ufshpb_get_lpn(struct scsi_cmnd *cmnd) > > +{ > > + return blk_rq_pos(cmnd->request) >> > > + (ilog2(cmnd->device->sector_size) - 9); > > +} > > Please use sectors_to_logical() from drivers/scsi/sd.h instead of open-coding > that function. OK, I will. > > +static inline unsigned int ufshpb_get_len(struct scsi_cmnd *cmnd) > > +{ > > + return blk_rq_sectors(cmnd->request) >> > > + (ilog2(cmnd->device->sector_size) - 9); > > +} > > Same comment here. OK > > +/* routine : READ10 -> HPB_READ */ > > Please expand this comment. OK Thanks, Daejun