On 2020-06-20 00:31, Kiwoong Kim wrote: > #define END_FIX { } The name of this macro is longer than its value. Additionally, this macro makes code harder to read instead of easier. Please include a patch to remove this macro from the UFS driver. > +#define UFS_DEV_VAL(_vendor, _model, _key, _val) { \ > + .wmanufacturerid = (_vendor),\ > + .model = (_model), \ > + .key = (_key), \ > + .val = (_val), \ > +} A macro like the above also makes code harder to read instead of easier. Please remove this macro definition and use the designated initialization style directly. Thanks, Bart.