On Mon, Jan 22, 2007 at 01:21:28AM +0200, Boaz Harrosh wrote: > - Introduce a new enum dma_data_direction data_dir member in struct request. > and remove the RW bit from request->cmd_flag Some architecture use 'enum dma_data_direction' and some 'int dma_data_direction'. The consensus was to move to int over time. Please use 'int dma_data_direction'. > diff --git a/include/linux/dma-mapping.h b/include/linux/dma-mapping.h > index ff203c4..abbca7b 100644 > --- a/include/linux/dma-mapping.h > +++ b/include/linux/dma-mapping.h > @@ -13,6 +13,28 @@ enum dma_data_direction { > DMA_NONE = 3, > }; > > +static inline int dma_write_dir(enum dma_data_direction dir) > +{ > + return (dir == DMA_TO_DEVICE) || (dir == DMA_BIDIRECTIONAL); > +} "write" can mean "write to device" or "write to memory", depending on context. Not exactly something which should be a generic helper. Rename to 'dma_to_device(int dir)'? > +static inline int dma_uni_dir(enum dma_data_direction dir) > +{ > + return (dir == DMA_TO_DEVICE) || (dir == DMA_FROM_DEVICE) || > + (dir == DMA_NONE); > +} While this doesn't look very useful. Why is "DMA_NONE" a uni-dir? I suggest replacing this with an open coded (dir != DMA_BIDIRECTIONAL). Cheers, Muli - To unsubscribe from this list: send the line "unsubscribe linux-scsi" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html