Looks good to me. Thanks, Avri > > > Hi, > This series adds trace event for UIC commands and do a small cleanup in > struct uic_command. > > v2 -> v3: > - Refactor "complete" event hooks in ufshcd_uic_cmd_compl() (Avri Altman) > > v1 -> v2: > - Rename "uic_send" to "send" and "uic_complete" to "complete" > - Move "send" trace before UIC command is sent otherwise "send" trace may > log incorrect arguments > - Move "complete" trace to UIC interrupt handler to make logging time > precise > > Stanley Chu (2): > scsi: ufs: Remove unused field in struct uic_command > scsi: ufs: Add trace event for UIC commands > > drivers/scsi/ufs/ufshcd.c | 26 ++++++++++++++++++++++++++ > drivers/scsi/ufs/ufshcd.h | 4 ---- > include/trace/events/ufs.h | 31 +++++++++++++++++++++++++++++++ > 3 files changed, 57 insertions(+), 4 deletions(-) > > -- > 2.18.0