On 2020-03-02 10:43, Daniel Wagner wrote: > On Sun, Mar 01, 2020 at 07:30:23PM -0800, Bart Van Assche wrote: >> -#define RD_REG_BYTE(addr) readb(addr) >> -#define RD_REG_WORD(addr) readw(addr) >> -#define RD_REG_DWORD(addr) readl(addr) >> -#define RD_REG_BYTE_RELAXED(addr) readb_relaxed(addr) >> -#define RD_REG_WORD_RELAXED(addr) readw_relaxed(addr) >> -#define RD_REG_DWORD_RELAXED(addr) readl_relaxed(addr) >> -#define WRT_REG_BYTE(addr, data) writeb(data, addr) >> -#define WRT_REG_WORD(addr, data) writew(data, addr) >> -#define WRT_REG_DWORD(addr, data) writel(data, addr) >> +static inline u8 RD_REG_BYTE(const volatile u8 __iomem *addr) >> +{ >> + return readb(addr); >> +} > > I would prefer lower case for the inline function names. How about doing that as a separate patch such that this patch can remain small and readable? Thanks, Bart.