Hi Jens, > > void blk_set_runtime_active(struct request_queue *q) > > { > > + if (!q->dev) > > + return; > > + > > spin_lock_irq(&q->queue_lock); > > q->rpm_status = RPM_ACTIVE; > > pm_runtime_mark_last_busy(q->dev); > > I'd prefer just doing: > > if (q->dev) { > ... > } > > instead. Other than that little complaint, looks good to me. > OK! I will change it in v2. Thanks, Stanley