Re: [PATCH 02/24] scsi: add scsi_{get,put}_reserved_cmd()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 5/29/19 5:12 PM, Bart Van Assche wrote:
On 5/29/19 6:28 AM, Hannes Reinecke wrote:
+    rq = blk_mq_alloc_request(sdev->request_queue,
+                  REQ_OP_SCSI_OUT | REQ_NOWAIT,
+                  BLK_MQ_REQ_RESERVED);

This looks wrong to me. To avoid that blk_mq_alloc_request() waits I think it should be called as follows:

     rq = blk_mq_alloc_request(sdev->request_queue,
             REQ_OP_SCSI_OUT,
             BLK_MQ_REQ_RESERVED | BLK_MQ_REQ_NOWAIT);

Bart.
Ah. Right.
Will be changing it.

Cheers,

Hannes
--
Dr. Hannes Reinecke            Teamlead Storage & Networking
hare@xxxxxxx                              +49 911 74053 688
SUSE LINUX GmbH, Maxfeldstr. 5, 90409 Nürnberg
GF: Felix Imendörffer, Mary Higgins, Sri Rasiah
HRB 21284 (AG Nürnberg)



[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Index of Archives]     [SCSI Target Devel]     [Linux SCSI Target Infrastructure]     [Kernel Newbies]     [IDE]     [Security]     [Git]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux ATA RAID]     [Linux IIO]     [Samba]     [Device Mapper]

  Powered by Linux