James, Not a fan of these: > +static int > +lpfc_is_scan_cmd(uint8_t opcode) > +{ > + switch (opcode & 0x1f) { > + case LPFC_INQUIRY_CMD_CODE: > + case LPFC_LOG_SELECT_CMD_CODE: > + case LPFC_LOG_SENSE_CMD_CODE: Especially since they are masked off twice: > +#define LPFC_INQUIRY_CMD_CODE (INQUIRY & 0x1f) > +#define LPFC_LOG_SELECT_CMD_CODE (LOG_SELECT & 0x1f) > +#define LPFC_LOG_SENSE_CMD_CODE (LOG_SENSE & > 0x1f) -- Martin K. Petersen Oracle Linux Engineering