On Fri, 2018-03-30 at 15:07 +0530, Chaitra P B wrote: > + if (((reply_pool_start_address / bit_divisor_16) / (bit_divisor_16)) == > + ((reply_pool_end_address / bit_divisor_16) / bit_divisor_16)) > + return 1; > + else > + return 0; Please use upper_32_bits() instead of open-coding it. I think that the above check could be rewritten as follows: return upper_32_bits(reply_pool_start_address) == upper_32_bits(reply_pool_end_address); Thanks, Bart.