On Mon, 2017-08-28 at 17:49 +0530, Alim Akhtar wrote: > This entire file uses UFS_BIT macro for bits definition, expect for few > places. This patch convert those defines to use UFS_BIT macro to be aligned > with reset of the file. This is the definition of the UFS_BIT() macro I found in drivers/scsi/ufs/ufshci.h: #define UFS_BIT(x) (1L << (x)) Using this macro makes code longer instead of shorter and does not improve code readability. Is this macro really useful? Wouldn't it be better to remove the UFS_BIT() macro instead of introducing more uses of it? Thanks, Bart.