Re: [PATCH 17/25] qla2xxx: Cleanup debug messager IDs.

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi Bart, 

> On May 19, 2017, at 4:23 PM, Bart Van Assche <bart.vanassche@xxxxxxxxxxx> wrote:
> 
> On Fri, 2017-05-19 at 14:53 -0700, Himanshu Madhani wrote:
>> diff --git a/drivers/scsi/qla2xxx/qla_attr.c b/drivers/scsi/qla2xxx/qla_attr.c
>> index 7c8d6c54ab70..a7ac81b473a4 100644
>> --- a/drivers/scsi/qla2xxx/qla_attr.c
>> +++ b/drivers/scsi/qla2xxx/qla_attr.c
>> @@ -44,7 +44,7 @@ qla2x00_sysfs_read_fw_dump(struct file *filp, struct kobject *kobj,
>> 		    MCTP_DUMP_SIZE);
>> 	else if (ha->fw_dump_reading)
>> 		return memory_read_from_buffer(buf, count, &off, ha->fw_dump,
>> -					ha->fw_dump_len);
>> +		    ha->fw_dump_len);
>> 	else
>> 		return 0;
>> }
>> @@ -162,7 +162,7 @@ qla2x00_sysfs_read_nvram(struct file *filp, struct kobject *kobj,
>> 		ha->isp_ops->read_optrom(vha, ha->nvram, ha->flt_region_nvram << 2,
>> 		    ha->nvram_size);
>> 	return memory_read_from_buffer(buf, count, &off, ha->nvram,
>> -					ha->nvram_size);
>> +	    ha->nvram_size);
>> }
>> 
>> static ssize_t
>> @@ -406,8 +406,8 @@ qla2x00_sysfs_write_optrom_ctl(struct file *filp, struct kobject *kobj,
>> 		    start == (ha->flt_region_fw * 4))
>> 			valid = 1;
>> 		else if (IS_QLA24XX_TYPE(ha) || IS_QLA25XX(ha)
>> -			|| IS_CNA_CAPABLE(ha) || IS_QLA2031(ha)
>> -			|| IS_QLA27XX(ha))
>> +		    || IS_CNA_CAPABLE(ha) || IS_QLA2031(ha)
>> +		    || IS_QLA27XX(ha))
>> 			valid = 1;
>> 		if (!valid) {
>> 			ql_log(ql_log_warn, vha, 0x7065,
> [ ... ]
>> @@ -1295,7 +1295,7 @@ qla24xx_84xx_fw_version_show(struct device *dev,
>> 
>> 	if ((rval == QLA_SUCCESS) && (status[0] == 0))
>> 		return scnprintf(buf, PAGE_SIZE, "%u\n",
>> -			(uint32_t)ha->cs84xx->op_fw_version);
>> +		    (uint32_t)ha->cs84xx->op_fw_version);
>> 
>> 	return scnprintf(buf, PAGE_SIZE, "\n");
>> }
>> @@ -1608,7 +1608,7 @@ static void
>> qla2x00_get_host_speed(struct Scsi_Host *shost)
>> {
>> 	struct qla_hw_data *ha = ((struct scsi_qla_host *)
>> -					(shost_priv(shost)))->hw;
>> +	    (shost_priv(shost)))->hw;
>> 	u32 speed = FC_PORTSPEED_UNKNOWN;
>> 
>> 	if (IS_QLAFX00(ha)) {
>> @@ -1853,7 +1853,7 @@ qla2x00_get_fc_host_stats(struct Scsi_Host *shost)
>> 	    !ha->dpc_active) {
>> 		/* Must be in a 'READY' state for statistics retrieval. */
>> 		rval = qla2x00_get_link_status(base_vha, base_vha->loop_id,
>> -						stats, stats_dma);
>> +		    stats, stats_dma);
>> 	}
>> 
>> 	if (rval != QLA_SUCCESS)
>> 
> [ ... ]
>> @@ -2147,7 +2147,7 @@ qla8044_serdes_op(struct bsg_job *bsg_job)
>> 	bsg_job->reply_len = sizeof(struct fc_bsg_reply);
>> 	bsg_reply->result = DID_OK << 16;
>> 	bsg_job_done(bsg_job, bsg_reply->result,
>> -		       bsg_reply->reply_payload_rcv_len);
>> +	    bsg_reply->reply_payload_rcv_len);
>> 	return 0;
>> }
> [ ... ]
>> 			    "DMA allocation failed for %u\n",
>> -			     qla2x00_gid_list_size(ha));
>> +			    qla2x00_gid_list_size(ha));
>> 			return 0;
>> 		}
> [ ... ]
>> @@ -384,10 +384,10 @@ qla2x00_dfs_setup(scsi_qla_host_t *vha)
>> 	}
>> 
>> 	ha->tgt.dfs_tgt_sess = debugfs_create_file("tgt_sess",
>> -		S_IRUSR, ha->dfs_dir, vha, &dfs_tgt_sess_ops);
>> +	    S_IRUSR, ha->dfs_dir, vha, &dfs_tgt_sess_ops);
>> 	
> 
> Hello Himanshu and Quinn,
> 
> This kind of whitespace changes makes the code harder to read and is not useful in
> any way. Please remove all whitespace changes from this patch.
> 
> Thanks,
> 
> Bart.

Sure. Will update patch. 

Thanks,
- Himanshu





[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Index of Archives]     [SCSI Target Devel]     [Linux SCSI Target Infrastructure]     [Kernel Newbies]     [IDE]     [Security]     [Git]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux ATA RAID]     [Linux IIO]     [Samba]     [Device Mapper]

  Powered by Linux