On Mon, 2017-02-27 at 11:13 -0600, Steve Magnani wrote: > On 02/27/2017 10:13 AM, Bart Van Assche wrote: > > Why are the two checks slightly different? Could the same code be used for > > both checks? > > The checks are different because with READ CAPACITY(16) a _really_ huge > device could report a max LBA so large that left-shifting it causes bits > to drop off the end. That's not an issue with READ CAPACITY(10) because > at most the 32-bit LBA reported by the device will become a 35-bit value > (since the max supported block size is 4096 == (512 << 3)). Sorry but I still don't understand why the two checks are different. How about the (untested) patch below? The approach below avoids that the check is duplicated and - at least in my opinion - results in code that is easier to read. Thanks, Bart. diff --git a/drivers/scsi/sd.c b/drivers/scsi/sd.c index cb6e68dd6df0..3533d1e46bde 100644 --- a/drivers/scsi/sd.c +++ b/drivers/scsi/sd.c @@ -2082,6 +2082,16 @@ static void read_capacity_error(struct scsi_disk *sdkp, struct scsi_device *sdp, sdkp->capacity = 0; /* unknown mapped to zero - as usual */ } +/* + * Check whether or not logical_to_sectors(sdp, lba) will overflow. + */ +static bool lba_too_large(u64 lba, u32 logical_block_size) +{ + int shift = sizeof(sector_t) * 8 + 9 - ilog2(logical_block_size); + + return shift >= 0 && shift < 64 && lba >= (1ULL << shift); +} + #define RC16_LEN 32 #if RC16_LEN > SD_BUF_SIZE #error RC16_LEN must not be more than SD_BUF_SIZE @@ -2154,7 +2164,7 @@ static int read_capacity_16(struct scsi_disk *sdkp, struct scsi_device *sdp, return -ENODEV; } - if ((sizeof(sdkp->capacity) == 4) && (lba >= 0xffffffffULL)) { + if (lba_too_large(lba + 1, sector_size)) { sd_printk(KERN_ERR, sdkp, "Too big for this kernel. Use a " "kernel compiled with support for large block " "devices.\n"); @@ -2243,7 +2253,7 @@ static int read_capacity_10(struct scsi_disk *sdkp, struct scsi_device *sdp, return sector_size; } - if ((sizeof(sdkp->capacity) == 4) && (lba == 0xffffffff)) { + if (lba_too_large(lba + 1ULL, sector_size)) { sd_printk(KERN_ERR, sdkp, "Too big for this kernel. Use a " "kernel compiled with support for large block " "devices.\n"); -- 2.11.0