Re: [PATCH 00/20] libfc callback cleanup

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Tue, 18 Oct 2016, 8:01am -0000, Hannes Reinecke wrote:

> Hi all,
> 
> it has been bugging me for a while that libfc has tons of callbacks
> in an attempt to abstract things away. But as it turned out
> no-one ever used those, rendering them quite pointless.
> As I got some time to kill on the train back from Vienna I've decided
> to finally kill them and call the functions directly.
> 
> As usual, comments and reviews are welcome.
> 
> Hannes Reinecke (20):
>   libfc: Replace ->seq_els_rsp_send callback with function call
>   libfc: Replace ->lport_reset callback with function call
>   libfc: Replace ->lport_recv with function call
>   libfc: Replace ->exch_seq_send callback with function call
>   libfc: Replace ->rport_destroy callback with function call
>   libfc: Replace ->rport_lookup callback with function call
>   scsi_transport_fc: rename 'fc_rport_create' to 'fc_remote_port_create'
>   libfc: Replace ->rport_create callback with function call
>   libfc: Replace ->rport_login callback with function call
>   libfc: Replace ->rport_logoff callback with function call
>   libfc: Replace ->rport_recv_req callback with function call
>   libfc: Replace ->rport_flush_queue callback with function call
>   libfc: Remove fc_rport_init()
>   libfc: Replace ->seq_send callback with function call
>   libfc: Replace ->seq_exch_abort callback with function call
>   libfc: Replace ->exch_done callback with function call
>   libfc: Replace ->seq_start_next callback with function call
>   libfc: Replace ->seq_set_resp callback with direct function call
>   libfc: Replace ->seq_assign callback with function call
>   libfc: Replace ->seq_release callback with function call
> 
>  drivers/scsi/bnx2fc/bnx2fc_fcoe.c |   1 -
>  drivers/scsi/bnx2fc/bnx2fc_tgt.c  |   3 +-
>  drivers/scsi/fcoe/fcoe_ctlr.c     |  35 ++++---
>  drivers/scsi/fnic/fnic_scsi.c     |   2 +-
>  drivers/scsi/libfc/fc_disc.c      |  33 ++++---
>  drivers/scsi/libfc/fc_elsct.c     |   2 +-
>  drivers/scsi/libfc/fc_exch.c      | 104 ++++++++++----------
>  drivers/scsi/libfc/fc_fcp.c       |  45 ++++-----
>  drivers/scsi/libfc/fc_libfc.c     |   2 +-
>  drivers/scsi/libfc/fc_lport.c     |  62 ++++++------
>  drivers/scsi/libfc/fc_rport.c     | 167 ++++++++++++++------------------
>  drivers/scsi/scsi_transport_fc.c  |   8 +-
>  drivers/target/tcm_fc/tfc_cmd.c   |  20 ++--
>  drivers/target/tcm_fc/tfc_io.c    |   4 +-
>  include/scsi/libfc.h              | 195 ++++++--------------------------------
>  15 files changed, 254 insertions(+), 429 deletions(-)
> 

Hannes, thanks for doing this.  Should make the code much more readable. 
--
To unsubscribe from this list: send the line "unsubscribe linux-scsi" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html



[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Index of Archives]     [SCSI Target Devel]     [Linux SCSI Target Infrastructure]     [Kernel Newbies]     [IDE]     [Security]     [Git]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux ATA RAID]     [Linux IIO]     [Samba]     [Device Mapper]
  Powered by Linux