Wolfram, Thanks for the review. New patch was just sent. :) On Sun, Feb 10, 2013 at 4:19 AM, Wolfram Sang <w.sang@xxxxxxxxxxxxxx> wrote: >> +static int i2c_get_number_from_dt(struct i2c_adapter *adap) > > i2c_get_id_from_dt()? Done. >> + if (!dev->of_node) >> + return -1; > > -ESOMETHING? Function has been removed, as per below. >> + >> + id = of_alias_get_id(dev->of_node, "i2c"); >> + if (id < 0) >> + return -1; >> + return id; > > Simply 'return of_alias_get_id(...)'? Even more, since this function > boils down to calling of_alias_get_id only and is only used once, I'd > think we can implement that directly and drop this function. That > shouldn't hurt readability. Good point. Done. >> +/** >> + * _i2c_add_numbered_adapter - i2c_add_numbered_adapter where nr is never -1 >> + * @adap: the adapter to register (with adap->nr initialized) >> + * Context: can sleep >> + * >> + * See i2c_add_numbered_adapter() for details. >> + */ >> +static int _i2c_add_numbered_adapter(struct i2c_adapter *adap) > > All other internal functions are prefixed with '__'. Done. >> +{ >> + int id; >> + int status; >> + >> + /* Handled by wrappers */ >> + BUG_ON(adap->nr == -1); > > Is that a reason to halt the kernel? WARN and bailing out would do IMO. Done. >> + >> + if (adap->nr & ~MAX_IDR_MASK) >> + return -EINVAL; > > Note the idr-cleanup series from Tejun Heo. Given that his series is > scheduled for v3.9, I'd like to have your patches on top of his. Done. -- To unsubscribe from this list: send the line "unsubscribe linux-samsung-soc" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html