Hi, On Wed, Mar 21, 2012 at 08:11:52PM +0100, Karol Lewandowski wrote: > Reorganize driver a bit to better handle device tree-based systems: > > - move machine type to driver's private structure instead of > quering platform device variants in runtime > > - replace s3c24xx_i2c_type enum with unsigned int that holds > bitmask with revision-specific quirks > > Signed-off-by: Karol Lewandowski <k.lewandowsk@xxxxxxxxxxx> > Signed-off-by: Kyungmin Park <kyungmin.park@xxxxxxxxxxx> Okay, so this driver needs to the 'data' field from either platform_device_id or of_device_id and implements a function for that, namely s3c24xx_get_device_quirks(). Grant, Rob: I'd think there might be more drivers in need of that, so maybe it makes sense to have a generic of-helper function? > --- > drivers/i2c/busses/i2c-s3c2410.c | 47 ++++++++++++++++++------------------- > 1 files changed, 23 insertions(+), 24 deletions(-) > > diff --git a/drivers/i2c/busses/i2c-s3c2410.c b/drivers/i2c/busses/i2c-s3c2410.c > index 85e3664..f7b6a14 100644 > --- a/drivers/i2c/busses/i2c-s3c2410.c > +++ b/drivers/i2c/busses/i2c-s3c2410.c > @@ -44,8 +44,14 @@ > #include <plat/regs-iic.h> > #include <plat/iic.h> > > -/* i2c controller state */ > +#ifdef CONFIG_OF > +static const struct of_device_id s3c24xx_i2c_match[]; > +#endif Uh, forward declaration with #ifdef. I'd think we should get this simply to the front. > dd > +/* Treat S3C2410 as baseline hardware, anything else is supported via quirks */ > +#define QUIRK_S3C2440 (1 << 0) Minor: Is it really a quirk being s3c2440? Maybe FLAG_*, dunno. > + > +/* i2c controller state */ > enum s3c24xx_i2c_state { > STATE_IDLE, > STATE_START, > @@ -54,14 +60,10 @@ enum s3c24xx_i2c_state { > STATE_STOP > }; > > -enum s3c24xx_i2c_type { > - TYPE_S3C2410, > - TYPE_S3C2440, > -}; > - > struct s3c24xx_i2c { > spinlock_t lock; > wait_queue_head_t wait; > + unsigned int quirks; > unsigned int suspended:1; > > struct i2c_msg *msg; > @@ -88,26 +90,22 @@ struct s3c24xx_i2c { > #endif > }; > > -/* default platform data removed, dev should always carry data. */ > - > -/* s3c24xx_i2c_is2440() > +/* s3c24xx_get_device_quirks > * > - * return true is this is an s3c2440 > + * Get controller type either from device tree or platform device variant. > */ > > -static inline int s3c24xx_i2c_is2440(struct s3c24xx_i2c *i2c) > +static inline unsigned int s3c24xx_get_device_quirks(struct platform_device *pdev) > { > - struct platform_device *pdev = to_platform_device(i2c->dev); > - enum s3c24xx_i2c_type type; > - > #ifdef CONFIG_OF > - if (i2c->dev->of_node) > - return of_device_is_compatible(i2c->dev->of_node, > - "samsung,s3c2440-i2c"); > + if (pdev->dev.of_node) { > + const struct of_device_id *match; > + match = of_match_node(&s3c24xx_i2c_match[0], pdev->dev.of_node); Minor: I think it is more readable to drop the [0] > + return (unsigned int)match->data; > + } > #endif > > - type = platform_get_device_id(pdev)->driver_data; > - return type == TYPE_S3C2440; > + return platform_get_device_id(pdev)->driver_data; > } > > /* s3c24xx_i2c_master_complete > @@ -676,7 +674,7 @@ static int s3c24xx_i2c_clockrate(struct s3c24xx_i2c *i2c, unsigned int *got) > > writel(iiccon, i2c->regs + S3C2410_IICCON); > > - if (s3c24xx_i2c_is2440(i2c)) { > + if (i2c->quirks & QUIRK_S3C2440) { > unsigned long sda_delay; > > if (pdata->sda_delay) { > @@ -906,6 +904,7 @@ static int s3c24xx_i2c_probe(struct platform_device *pdev) > goto err_noclk; > } > > + i2c->quirks = s3c24xx_get_device_quirks(pdev); > if (pdata) > memcpy(i2c->pdata, pdata, sizeof(*pdata)); > else > @@ -1113,18 +1112,18 @@ static const struct dev_pm_ops s3c24xx_i2c_dev_pm_ops = { > static struct platform_device_id s3c24xx_driver_ids[] = { > { > .name = "s3c2410-i2c", > - .driver_data = TYPE_S3C2410, > + .driver_data = 0, > }, { > .name = "s3c2440-i2c", > - .driver_data = TYPE_S3C2440, > + .driver_data = QUIRK_S3C2440, > }, { }, > }; > MODULE_DEVICE_TABLE(platform, s3c24xx_driver_ids); > > #ifdef CONFIG_OF > static const struct of_device_id s3c24xx_i2c_match[] = { > - { .compatible = "samsung,s3c2410-i2c" }, > - { .compatible = "samsung,s3c2440-i2c" }, > + { .compatible = "samsung,s3c2410-i2c", .data = (void *)0 }, > + { .compatible = "samsung,s3c2440-i2c", .data = (void *)QUIRK_S3C2440 }, Hmm, the need to sepcify the quirks twice may lead to only one instance being updated in future patches, but I don't see a way around that, currently :( > {}, > }; > MODULE_DEVICE_TABLE(of, s3c24xx_i2c_match); > -- > 1.7.9 > Thanks, Wolfram -- Pengutronix e.K. | Wolfram Sang | Industrial Linux Solutions | http://www.pengutronix.de/ |
Attachment:
signature.asc
Description: Digital signature