Op 03-07-10 03:21, Kukjin Kim schreef: > Maurus Cuelenaere wrote: >> Op 03-07-10 02:07, Kukjin Kim schreef: >> >>> /* S3C6400 SDHCI setup */ >>> >>> @@ -264,10 +267,22 @@ static inline void s5pv210_default_sdhci2(void) >>> static inline void s5pv210_default_sdhci2(void) { } >>> #endif /* CONFIG_S3C_DEV_HSMMC2 */ >>> >>> +#ifdef CONFIG_S3C_DEV_HSMMC3 >>> +static inline void s5pv210_default_sdhci3(void) >>> +{ >>> + s3c_hsmmc3_def_platdata.clocks = s5pv210_hsmmc_clksrcs; >>> + s3c_hsmmc3_def_platdata.cfg_gpio = s5pv210_setup_sdhci3_cfg_gpio; >>> + s3c_hsmmc3_def_platdata.cfg_card = s5pv210_setup_sdhci_cfg_card; >>> +} >>> +#else >>> +static inline void s5pv210_default_sdhci3(void) { } >>> +#endif /* CONFIG_S3C_DEV_HSMMC3 */ >> This could be simplified by putting the #ifdef inside the function. > Yeah, you're right..but used same style with others in this file. > ...so will modify it as your comment with others soon. Hmm yes, I guess it's just a matter of personal taste. -- Maurus Cuelenaere -- To unsubscribe from this list: send the line "unsubscribe linux-samsung-soc" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html