On Tue, Aug 13, 2024 at 02:43:33PM +0200, Greg Kroah-Hartman wrote: > On Tue, Aug 13, 2024 at 01:50:27PM +0200, Vasily Gorbik wrote: > > On Tue, Aug 13, 2024 at 12:52:19PM +0200, Greg Kroah-Hartman wrote: > > > On Tue, Aug 13, 2024 at 12:42:37PM +0200, Vasily Gorbik wrote: > > > > From: Heiko Carstens <hca@xxxxxxxxxxxxx> > > > > > > > > iucv_alloc_device() gets a format string and a varying number of > > > > arguments. This is incorrectly forwarded by calling dev_set_name() with > > > > the format string and a va_list, while dev_set_name() expects also a > > > > varying number of arguments. > > > > > > > > Fix this and call kobject_set_name_vargs() instead which expects a > > > > va_list parameter. > > > > > > I don't understand, why can't dev_set_name() be called here? > > > > > > Calling "raw" kobject functions is almost never the correct thing to be > > > doing, ESPECIALLY as you have a struct device here. > > > > struct device *iucv_alloc_device(const struct attribute_group **attrs, > > void *priv, const char *fmt, ...); > > > > va_start(vargs, fmt); initializes vargs to point to the first argument after fmt. > > > > __printf(2, 0) int kobject_set_name_vargs(struct kobject *kobj, const char *fmt, va_list vargs); > > > > __printf(2, 3) int dev_set_name(struct device *dev, const char *name, ...); > > > > dev_set_name is expecting to receive individual variable arguments > > directly (...), not a va_list. > > > > The (...) in dev_set_name is meant to be expanded into individual > > arguments, but when you pass a va_list to it, this expansion doesn't > > happen. Instead, the va_list is just treated as a pointer or a single > > argument, leading to undefined or incorrect behavior. > > > > So, would it be okay to reuse kobject_set_name_vargs() here, or would you propose > > introducing another helper just for this case? e.g. > > > > int dev_set_name_vargs(struct device *dev, const char *fmt, va_list vargs) > > { > > ჻·······return kobject_set_name_vargs(&dev->kobj, fmt, vargs); > > } > > EXPORT_SYMBOL_GPL(dev_set_name_vargs) > > This function makes more sense if you really want to do this. > > But step back, why is this needed at all anyway? No other subsystem or > driver needs/wants this, what makes this api so special? Why not figure > out your name beforehand? That's comming from this patch series: https://lore.kernel.org/all/20240506194454.1160315-1-hca@xxxxxxxxxxxxx/#t """ Unify IUCV device allocation as suggested by Arnd Bergmann in order to get rid of code duplication in various device drivers. """ It just introduces and utilizes a couple of wrappers to reduce code duplication, and in this case, introducing this level of indirection led to the need for forwarding vargs. And reimplementing parts of kobject_set_name_vargs to format the device name beforehand is probably not what we want.