Re: [PATCH 4/4] vdso: avoid including asm/page.h

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 




Le 26/02/2024 à 17:14, Arnd Bergmann a écrit :
> From: Arnd Bergmann <arnd@xxxxxxxx>
> 
> The recent change to the vdso_data_store broke building compat VDSO
> on at least arm64 because it includes headers outside of the include/vdso/
> namespace:

I understand that powerpc64 also has an issue, see 
https://patchwork.ozlabs.org/project/linuxppc-dev/patch/20231221120410.2226678-1-mpe@xxxxxxxxxxxxxx/

> 
> In file included from arch/arm64/include/asm/lse.h:5,
>                   from arch/arm64/include/asm/cmpxchg.h:14,
>                   from arch/arm64/include/asm/atomic.h:16,
>                   from include/linux/atomic.h:7,
>                   from include/asm-generic/bitops/atomic.h:5,
>                   from arch/arm64/include/asm/bitops.h:25,
>                   from include/linux/bitops.h:68,
>                   from arch/arm64/include/asm/memory.h:209,
>                   from arch/arm64/include/asm/page.h:46,
>                   from include/vdso/datapage.h:22,
>                   from lib/vdso/gettimeofday.c:5,
>                   from <command-line>:
> arch/arm64/include/asm/atomic_ll_sc.h:298:9: error: unknown type name 'u128'
>    298 |         u128 full;
> 
> Use an open-coded page size calculation based on the new CONFIG_PAGE_SHIFT
> Kconfig symbol instead.
> 
> Reported-by: Linux Kernel Functional Testing <lkft@xxxxxxxxxx>
> Fixes: a0d2fcd62ac2 ("vdso/ARM: Make union vdso_data_store available for all architectures")
> Link: https://lore.kernel.org/lkml/CA+G9fYtrXXm_KO9fNPz3XaRxHV7UD_yQp-TEuPQrNRHU+_0W_Q@xxxxxxxxxxxxxx/
> Signed-off-by: Arnd Bergmann <arnd@xxxxxxxx>
> ---
>   include/vdso/datapage.h | 4 +---
>   1 file changed, 1 insertion(+), 3 deletions(-)
> 
> diff --git a/include/vdso/datapage.h b/include/vdso/datapage.h
> index 7ba44379a095..2c39a67d7e23 100644
> --- a/include/vdso/datapage.h
> +++ b/include/vdso/datapage.h
> @@ -19,8 +19,6 @@
>   #include <vdso/time32.h>
>   #include <vdso/time64.h>
>   
> -#include <asm/page.h>
> -
>   #ifdef CONFIG_ARCH_HAS_VDSO_DATA
>   #include <asm/vdso/data.h>
>   #else
> @@ -128,7 +126,7 @@ extern struct vdso_data _timens_data[CS_BASES] __attribute__((visibility("hidden
>    */
>   union vdso_data_store {
>   	struct vdso_data	data[CS_BASES];
> -	u8			page[PAGE_SIZE];
> +	u8			page[1ul << CONFIG_PAGE_SHIFT];

Usually 1UL is used (capital letter)

Maybe better to (re)define PAGE_SIZE instead, something like:

#define PAGE_SIZE (1UL << CONFIG_PAGE_SHIFT)


>   };
>   
>   /*




[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Index of Archives]     [Kernel Development]     [Kernel Newbies]     [IDE]     [Security]     [Git]     [Netfilter]     [Bugtraq]     [Yosemite Info]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux ATA RAID]     [Samba]     [Linux Media]     [Device Mapper]

  Powered by Linux