Hello Linus, please pull the second round of s390 changes for 5.18. Thank you, Vasily The following changes since commit d710d370c4911e83da5d2bc43d4a2c3b56bd27e7: Merge tag 's390-5.18-1' of git://git.kernel.org/pub/scm/linux/kernel/git/s390/linux (2022-03-25 10:01:34 -0700) are available in the Git repository at: git://git.kernel.org/pub/scm/linux/kernel/git/s390/linux.git tags/s390-5.18-2 for you to fetch changes up to faf79934e65aff90284725518a5ec3c2241c65ae: s390/alternatives: avoid using jgnop mnemonic (2022-03-28 23:27:54 +0200) ---------------------------------------------------------------- s390 updates for the 5.18 merge window #2 - Add kretprobes framepointer verification and return address recovery in stacktrace. - Support control domain masks on custom zcrypt devices and filter admin requests. - Cleanup timer API usage. - Rework absolute lowcore access helpers. - Other various small improvements and fixes. ---------------------------------------------------------------- Alexander Gordeev (4): s390/smp: cleanup target CPU callback starting s390/smp: cleanup control register update routines s390/maccess: rework absolute lowcore accessors s390/smp: use physical address for SIGP_SET_PREFIX command Haowen Bai (2): s390: crypto: Use min_t() instead of doing it manually s390/tape: use bitwise instead of arithmetic operator for flags Heiko Carstens (5): s390/traps: improve panic message for translation-specification exception s390/alternatives: use instructions instead of byte patterns s390/alternatives: use insn format for new instructions s390/ap: use insn format for new instructions s390/ap: adjust whitespace Jakob Koschel (1): s390/zcrypt: fix using the correct variable for sizeof() Juergen Christ (2): s390/zcrypt: Add admask to zcdn s390/zcrypt: Filter admin CPRBs on custom devices Julia Lawall (1): s390/pkey: fix typos in comments Niklas Schnelle (2): s390/pci: improve zpci_dev reference counting s390/pci: rename get_zdev_by_bus() to zdev_from_bus() Russell Currey (1): s390: fix typo in syscall_wrapper.h Tony Krowiak (1): s390/vfio-ap: fix kernel doc and signature of group notifier functions Vasily Gorbik (6): s390/test_unwind: extend kretprobe test s390/kprobes: enable kretprobes framepointer verification s390/unwind: recover kretprobe modified return address in stacktrace s390/unwind: avoid duplicated unwinding entries for kretprobes s390/test_unwind: verify __kretprobe_trampoline is replaced s390/alternatives: avoid using jgnop mnemonic Yu Liao (1): s390: cleanup timer API use arch/s390/Kconfig | 1 + arch/s390/include/asm/alternative-asm.h | 12 ++++-- arch/s390/include/asm/alternative.h | 15 ++++++-- arch/s390/include/asm/ap.h | 60 ++++++++++++++--------------- arch/s390/include/asm/ctl_reg.h | 16 +++++--- arch/s390/include/asm/processor.h | 17 ++++++--- arch/s390/include/asm/spinlock.h | 2 +- arch/s390/include/asm/syscall_wrapper.h | 2 +- arch/s390/include/asm/unwind.h | 13 +++++++ arch/s390/kernel/entry.S | 10 ++--- arch/s390/kernel/ipl.c | 4 +- arch/s390/kernel/kprobes.c | 8 ++-- arch/s390/kernel/machine_kexec.c | 2 +- arch/s390/kernel/os_info.c | 2 +- arch/s390/kernel/setup.c | 19 ++++----- arch/s390/kernel/smp.c | 57 +++++++++++++-------------- arch/s390/kernel/traps.c | 6 +-- arch/s390/kernel/unwind_bc.c | 12 ++---- arch/s390/lib/spinlock.c | 4 +- arch/s390/lib/test_unwind.c | 58 +++++++++++++++++++--------- arch/s390/pci/pci.c | 5 ++- arch/s390/pci/pci_bus.h | 7 ++-- arch/s390/pci/pci_clp.c | 9 ++++- arch/s390/pci/pci_event.c | 7 +++- drivers/s390/char/sclp.c | 4 +- drivers/s390/char/sclp_con.c | 3 +- drivers/s390/char/sclp_vt220.c | 6 +-- drivers/s390/char/tape_34xx.c | 4 +- drivers/s390/cio/device_fsm.c | 12 ++---- drivers/s390/cio/eadm_sch.c | 12 ++---- drivers/s390/crypto/ap_bus.h | 1 + drivers/s390/crypto/pkey_api.c | 2 +- drivers/s390/crypto/vfio_ap_ops.c | 24 +++--------- drivers/s390/crypto/zcrypt_api.c | 68 ++++++++++++++++++++++++++++++++- drivers/s390/crypto/zcrypt_card.c | 2 +- drivers/s390/crypto/zcrypt_ep11misc.c | 2 +- 36 files changed, 296 insertions(+), 192 deletions(-)