On Thu, 6 Jun 2019 22:28:31 +0200 Eric Farman <farman@xxxxxxxxxxxxx> wrote: > With both the direct-addressed and indirect-addressed CCW paths > simplified to this point, the amount of shared code between them is > (hopefully) more easily visible. Move the processing of IDA-specific > bits into the direct-addressed path, and add some useful commentary of > what the individual pieces are doing. This allows us to remove the > entire ccwchain_fetch_idal() routine and maintain a single function > for any non-TIC CCW. > > Signed-off-by: Eric Farman <farman@xxxxxxxxxxxxx> > --- > drivers/s390/cio/vfio_ccw_cp.c | 115 +++++++++++---------------------- > 1 file changed, 39 insertions(+), 76 deletions(-) Another nice cleanup :) > > diff --git a/drivers/s390/cio/vfio_ccw_cp.c b/drivers/s390/cio/vfio_ccw_cp.c > index 8205d0b527fc..90d86e1354c1 100644 > --- a/drivers/s390/cio/vfio_ccw_cp.c > +++ b/drivers/s390/cio/vfio_ccw_cp.c > @@ -534,10 +534,12 @@ static int ccwchain_fetch_direct(struct ccwchain *chain, The one minor thing I have is that the function name (ccwchain_fetch_direct) is now slightly confusing. But we can easily do a patch on top renaming it (if we can come up with a better name.) Reviewed-by: Cornelia Huck <cohuck@xxxxxxxxxx>