On 2/13/19 8:30 PM, Dave Hansen wrote: >> -#if (defined(CONFIG_MEMORY_ISOLATION) && defined(CONFIG_COMPACTION)) || defined(CONFIG_CMA) >> +#ifdef CONFIG_COMPACTION_CORE >> static __init int gigantic_pages_init(void) >> { >> /* With compaction or CMA we can allocate gigantic pages at runtime */ >> diff --git a/fs/Kconfig b/fs/Kconfig >> index ac474a61be37..8fecd3ea5563 100644 >> --- a/fs/Kconfig >> +++ b/fs/Kconfig >> @@ -207,8 +207,9 @@ config HUGETLB_PAGE >> config MEMFD_CREATE >> def_bool TMPFS || HUGETLBFS >> >> -config ARCH_HAS_GIGANTIC_PAGE >> +config COMPACTION_CORE >> bool >> + default y if (MEMORY_ISOLATION && MIGRATION) || CMA > > This takes a hard dependency (#if) and turns it into a Kconfig *default* > that can be overridden. That seems like trouble. > > Shouldn't it be: > > config COMPACTION_CORE > def_bool y > depends on (MEMORY_ISOLATION && MIGRATION) || CMA Agreed. Also I noticed that it now depends on MIGRATION instead of COMPACTION. That intention is correct IMHO, but will fail to compile/link when both COMPACTION and CMA are disabled, and would need more changes in mm/internal.h and mm/compaction.c (possibly just replacing CMA in all "if defined CONFIG_COMPACTION || defined CONFIG_CMA" instances with COMPACTION_CORE, but there might be more problems, wanna try? :) Also, I realized that COMPACTION_CORE is a wrong name, sorry about that. What the config really provides is alloc_contig_range(), so it should be named either CONFIG_CMA_CORE (as it provides contiguous memory allocation, but not the related reservation and accounting), or something like CONFIG_CONTIG_ALLOC. I would also move it from fs/Kconfig to mm/Kconfig. Thanks!