> >> >>> + >>> void sclp_memory_setup(void) >>> { >>> ReadInfo *ri = (void *)_sccb; >>> @@ -37,7 +76,10 @@ void sclp_memory_setup(void) >>> int cc; >>> >>> ri->h.length = SCCB_SIZE; >>> + sclp_busy = true; >>> sclp_service_call(SCLP_CMDW_READ_SCP_INFO_FORCED, ri); >>> + while (sclp_busy) >>> + /* Wait for SCLP request to complete */; >> >> Should we factor that out into something like > > As written above, I'm all for the second one, but I dislike the start > one liner. > Sure, fine with me! -- Thanks, David / dhildenb