On 06/09/2024 11:36, Junhao Xie wrote: > This commit adds support for Photonicat power management MCU on > Ariaboard Photonicat. > > Signed-off-by: Junhao Xie <bigfoot@xxxxxxxxxxx> > --- > .../boot/dts/rockchip/rk3568-photonicat.dts | 43 +++++++++++++++++++ > 1 file changed, 43 insertions(+) > > diff --git a/arch/arm64/boot/dts/rockchip/rk3568-photonicat.dts b/arch/arm64/boot/dts/rockchip/rk3568-photonicat.dts > index 2fe403cd61cb..597275702408 100644 > --- a/arch/arm64/boot/dts/rockchip/rk3568-photonicat.dts > +++ b/arch/arm64/boot/dts/rockchip/rk3568-photonicat.dts > @@ -513,6 +513,49 @@ &uart4 { > dma-names = "tx", "rx"; > status = "okay"; > /* Onboard power management MCU */ > + > + pcat_pmu: mcu { > + compatible = "ariaboard,photonicat-pmu"; > + current-speed = <115200>; > + local-address = <1>; > + remote-address = <1>; > + > + pcat_pmu_battery: supply-battery { Drop unused labels. Everywhere. You are not making the code more readable. > + compatible = "ariaboard,photonicat-pmu-supply"; > + label = "battery"; > + monitored-battery = <&battery>; > + power-supplies = <&pcat_pmu_charger>; Why do you reference internal design of the device as DTS? You cannot have here other power supply, can you? Best regards, Krzysztof