Datasheets: https://www.analog.com/media/en/technical-documentation/data-sheets/MAX31328.pdf https://www.analog.com/media/en/technical-documentation/data-sheets/MAX31329.pdf https://www.analog.com/media/en/technical-documentation/data-sheets/MAX31331.pdf https://www.analog.com/media/en/technical-documentation/data-sheets/MAX31334.pdf https://www.analog.com/media/en/technical-documentation/data-sheets/MAX31341B-MAX31341C.pdf https://www.analog.com/media/en/technical-documentation/data-sheets/MAX31342.pdf https://www.analog.com/media/en/technical-documentation/data-sheets/MAX31343.pdf changelog: since v7: - Rename variables and functions to reduce delta with existing max31335 driver - clean up some sparse warnings - Keep old dt-binding name since v6: - Roll changes into max31335 driver that was landed while this was in-flight. - Adjusted code order and variable names to reduce the delta with the max31335 since v5: - change of maintainer - use adi,ti-diode property - deal with oscillator fail and releasing SWRST since v4: - dt-binding: add enum value "2" to aux-voltage-chargable - dt-binding: remove adi,trickle-diode-enable - dt-binding: change description of trickle-resistor-ohms - dt-binding: reorder as in example schema - parse "wakeup-source" when irq not requested - remove limitation on max31328 irq and clockout - remove error and warning messages during trickle charger setup since v3: - dt-binding: remove interrupt names. - dt-binding: add description for "interrupts" property - dt-binding: replace deprecated property "trickle-diode-disable" by "aux-voltage-chargeable" - dt-binding: add new property "adi,trickle-diode-enable" - dt-binding: remove "wakeup-source" - use clear_bit instead of __clear_bit - use devm_of_clk_add_hw_provider instead of of_clk_add_provider - use chip_desc pointer as driver data instead of enum. since v2: - add "break" to fix warning: unannotated fall-through Reported-by: kernel test robot <lkp@xxxxxxxxx> since v1: - dt-binding: update title and description - dt-binding: remove last example - drop watchdog support - support reading 12Hr format instead of forcing 24hr at probe time - use "tm_year % 100" instead of range check - refactor max313xx_init for readability Ibrahim Tilki (2): rtc: max31335: Add support for additional chips dt-bindings: rtc: add max313xx RTCs .../devicetree/bindings/rtc/adi,max31335.yaml | 88 +- drivers/rtc/Kconfig | 2 +- drivers/rtc/rtc-max31335.c | 969 +++++++++++++----- 3 files changed, 779 insertions(+), 280 deletions(-) -- 2.43.2