[PATCH v7 0/2] drivers: rtc: add max313xx series rtc driver

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Datasheets:
  https://www.analog.com/media/en/technical-documentation/data-sheets/MAX31328.pdf
  https://www.analog.com/media/en/technical-documentation/data-sheets/MAX31329.pdf
  https://www.analog.com/media/en/technical-documentation/data-sheets/MAX31331.pdf
  https://www.analog.com/media/en/technical-documentation/data-sheets/MAX31334.pdf
  https://www.analog.com/media/en/technical-documentation/data-sheets/MAX31341B-MAX31341C.pdf
  https://www.analog.com/media/en/technical-documentation/data-sheets/MAX31342.pdf
  https://www.analog.com/media/en/technical-documentation/data-sheets/MAX31343.pdf

Note that I've only got access to a MAX31334 to test with. I'm relying on the
fact that Ibrahim would have been testing on the other variants through earlier
iterations of this series. I've also made a best effort attempt to integrate
the MAX31335 support with the more generic code but as the datasheet is not
public I can't be sure it's been done correctly and the MAX31335 has definitely
not been tested with this updated code (Antoniu if you could test it on your
hardware that would really help).

changelog:
since v6:
  - Roll changes into max31335 driver that was landed while this was
    in-flight.
  - Adjusted code order and variable names to reduce the delta with
    the max31335

since v5:
  - change of maintainer
  - use adi,ti-diode property
  - deal with oscillator fail and releasing SWRST

since v4:
  - dt-binding: add enum value "2" to aux-voltage-chargable
  - dt-binding: remove adi,trickle-diode-enable
  - dt-binding: change description of trickle-resistor-ohms
  - dt-binding: reorder as in example schema
  - parse "wakeup-source" when irq not requested
  - remove limitation on max31328 irq and clockout
  - remove error and warning messages during trickle charger setup

since v3:
  - dt-binding: remove interrupt names.
  - dt-binding: add description for "interrupts" property
  - dt-binding: replace deprecated property "trickle-diode-disable"
      by "aux-voltage-chargeable"
  - dt-binding: add new property "adi,trickle-diode-enable"
  - dt-binding: remove "wakeup-source"
  - use clear_bit instead of __clear_bit
  - use devm_of_clk_add_hw_provider instead of of_clk_add_provider
  - use chip_desc pointer as driver data instead of enum.

since v2:
  - add "break" to fix warning: unannotated fall-through
    Reported-by: kernel test robot <lkp@xxxxxxxxx>

since v1:
  - dt-binding: update title and description
  - dt-binding: remove last example
  - drop watchdog support
  - support reading 12Hr format instead of forcing 24hr at probe time
  - use "tm_year % 100" instead of range check
  - refactor max313xx_init for readability

Ibrahim Tilki (2):
  drivers: rtc: add max313xx series rtc driver
  dt-bindings: rtc: add max313xx RTCs

 .../devicetree/bindings/rtc/adi,max31335.yaml |   70 -
 .../devicetree/bindings/rtc/adi,max313xx.yaml |  167 +++
 drivers/rtc/Kconfig                           |    2 +-
 drivers/rtc/rtc-max31335.c                    | 1154 +++++++++++------
 4 files changed, 958 insertions(+), 435 deletions(-)
 delete mode 100644 Documentation/devicetree/bindings/rtc/adi,max31335.yaml
 create mode 100644 Documentation/devicetree/bindings/rtc/adi,max313xx.yaml

-- 
2.43.2





[Index of Archives]     [Linux Sound]     [ALSA Users]     [ALSA Devel]     [Linux Audio Users]     [Linux Media]     [Kernel]     [Gimp]     [Yosemite News]     [Linux Media]

  Powered by Linux