Use DEVICE_ATTR_RO macro helper instead of plain DEVICE_ATTR, which makes the code a bit shorter and easier to read. Signed-off-by: Zhen Lei <thunder.leizhen@xxxxxxxxxx> --- drivers/rtc/rtc-rs5c372.c | 12 ++++++------ 1 file changed, 6 insertions(+), 6 deletions(-) diff --git a/drivers/rtc/rtc-rs5c372.c b/drivers/rtc/rtc-rs5c372.c index 80980414890c703..eae0fbad64c109e 100644 --- a/drivers/rtc/rtc-rs5c372.c +++ b/drivers/rtc/rtc-rs5c372.c @@ -496,8 +496,8 @@ static const struct rtc_class_ops rs5c372_rtc_ops = { #if IS_ENABLED(CONFIG_RTC_INTF_SYSFS) -static ssize_t rs5c372_sysfs_show_trim(struct device *dev, - struct device_attribute *attr, char *buf) +static ssize_t trim_show(struct device *dev, + struct device_attribute *attr, char *buf) { int err, trim; @@ -507,10 +507,10 @@ static ssize_t rs5c372_sysfs_show_trim(struct device *dev, return sprintf(buf, "%d\n", trim); } -static DEVICE_ATTR(trim, S_IRUGO, rs5c372_sysfs_show_trim, NULL); +static DEVICE_ATTR_RO(trim); -static ssize_t rs5c372_sysfs_show_osc(struct device *dev, - struct device_attribute *attr, char *buf) +static ssize_t osc_show(struct device *dev, + struct device_attribute *attr, char *buf) { int err, osc; @@ -520,7 +520,7 @@ static ssize_t rs5c372_sysfs_show_osc(struct device *dev, return sprintf(buf, "%d.%03d KHz\n", osc / 1000, osc % 1000); } -static DEVICE_ATTR(osc, S_IRUGO, rs5c372_sysfs_show_osc, NULL); +static DEVICE_ATTR_RO(osc); static int rs5c_sysfs_register(struct device *dev) { -- 2.26.0.106.g9fadedd