This series cleans up the rt-numa.h header. As we have a hard dependency on libnuma we can simplify the code in cyclictest. This allows remove all the small helpers in rt_numa.h. And with this we can remove the header and reduce the confusion with rt-numa.h While at it, I simplified the --smp vs --affinity vs --threads logic. There is no need for additional variables to keep state. With this we also make --affinity to behave as with the rest of rt-tests. That is a plan -a will be the same as with -S. There is no need for -S anymore but I think we should leave it in place for backwards compatibility. I suspect, there must be a lot of muscle memory out there :) Since signaltest has the same code as cyclictest, cleanup this tool as well. With all those cleanups in cyclictest and signaltest, rt-numa.h contains only a three functions. The final part of the series is to remove unnecessary function arguments (max_cpus). This also fixes the theoretical problem that a sparse cpumask would not be handled correctly. v4: - build fix becaue of error.c -> rt-error.c v3: - added error handling for numa_on_node() return value - added 'Rename error.h to rt-error.h' patch - rebased, dropped applied patches - fixed SoBs and stearing vs sterring spelling error v2: - added more cleanup patches Daniel Wagner (16): cyclictest: Use numa API directly cyclictest: Mimic --smp behavior with --affinity cyclictest: Simplify --smp vs --affinity vs --threads argument logic signaltest: Use affinity_mask for steering thread placement signaltest: Simplify --smp vs --affinity vs --threads argument logic rt-numa: Remove unused definitions and numa_initialize() rt-numa: Add generic cpu_for_thread() helper rt-numa: Use mask size for iterator limit rt-numa: Remove max_cpus argument from parse_cpusmask signaltest: Remove unused max_cpus argument from process_options cyclictest: Remove unused max_cpus argument from process_options rt-numa: Use CPU_SETSIZE as upper loop limit rt-numa: Remove used max_cpus argument from cpu_for_thread() cyclictest: Remove max cpus used verbose information cyclictest: Remove unecessary local variable rt-tests: Rename error.h to rt-error.h Makefile | 2 +- src/cyclictest/cyclictest.c | 111 ++++++++++------------------ src/cyclictest/rt_numa.h | 96 ------------------------ src/include/pip_stress.h | 5 +- src/include/{error.h => rt-error.h} | 0 src/include/rt-numa.h | 13 +--- src/lib/{error.c => rt-error.c} | 2 +- src/lib/rt-numa.c | 42 +++++------ src/lib/rt-utils.c | 3 +- src/oslat/oslat.c | 5 +- src/pi_tests/pi_stress.c | 3 +- src/pmqtest/pmqtest.c | 6 +- src/ptsematest/ptsematest.c | 6 +- src/sched_deadline/cyclicdeadline.c | 6 +- src/signaltest/signaltest.c | 76 +++++-------------- src/sigwaittest/sigwaittest.c | 2 +- src/svsematest/svsematest.c | 3 +- 17 files changed, 99 insertions(+), 282 deletions(-) delete mode 100644 src/cyclictest/rt_numa.h rename src/include/{error.h => rt-error.h} (100%) rename src/lib/{error.c => rt-error.c} (98%) -- 2.30.0